IS-IS Over FR
1)IS-IS没有为FR设定特定的网络类型,所以FR全互联时可以Broadcast网络类型,否则更改为P2P网络类型
实验------P2P
连接两端都需要改成点到点子接口方式连接
实验------Broadcast
--------------------------------
R1
|(S1/0)
|
R2(S1/0)------FR-SW-------(S1/0)R3
--------------------------------
1.非全互联时DIS可能选举不对
R1------------R2
R1------------R3
配置如下
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 192.168.123.1 255.255.255.0
ip router isis
encapsulation frame-relay
serial restart_delay 0
frame-relay map clns 103 broadcast //有这条才能建立邻居,学路由哦
frame-relay map clns 102 broadcast
no frame-relay inverse-arp
!
router isis
net 49.0001.0000.0000.1111.00
is-type level-1
!
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 192.168.123.2 255.255.255.0
ip router isis
encapsulation frame-relay
serial restart_delay 0
frame-relay map clns 201 broadcast
no frame-relay inverse-arp
!
router isis
net 49.0001.0000.0000.2222.00
is-type level-1
!
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip router isis
!
interface Serial1/0
ip address 192.168.123.3 255.255.255.0
ip router isis
encapsulation frame-relay
serial restart_delay 0
frame-relay map clns 301 broadcast
no frame-relay inverse-arp
!
router isis
net 49.0001.0000.0000.3333.00
is-type level-1
!
------------------------------------------------------------------------
查看邻居和路由信息
R1#show clns neighbors
System Id Interface SNPA State Holdtime Type Protocol
R2 Se1/0 DLCI 102 Up 7 L1 IS-IS
R3 Se1/0 DLCI 103 Up 7 L1 IS-IS
R1查看R3为DIS
R1#show clns interface s1/0
Serial1/0 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 30 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: R3.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 2
Next IS-IS LAN Level-1 Hello in 844 milliseconds
R1
R2查看R2为DIS
R2#show clns in
R2#show clns interface s1/0
Serial1/0 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 3 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: R2.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
R2#
查看ISIS数据库
R1#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x0000000E 0x995F 689 0/0/0
R2.00-00 0x0000000C 0xBB36 752 0/0/0
R2.02-00 0x00000002 0xE7C3 662 0/0/0
R3.00-00 0x00000009 0x01A8 789 0/0/0
R3.01-00 0x00000002 0x99CE 655 0/0/0
R1#
R2#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x0000000E 0x995F 651 0/0/0
R2.00-00 * 0x0000000C 0xBB36 718 0/0/0
R2.02-00 * 0x00000002 0xE7C3 628 0/0/0
R3.00-00 0x00000009 0x01A8 752 0/0/0
R2#
R3#show isis database
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x0000000E 0x995F 643 0/0/0
R2.00-00 0x0000000C 0xBB36 707 0/0/0
R2.02-00 0x00000002 0xE7C3 617 0/0/0
R3.00-00 * 0x00000009 0x01A8 748 0/0/0
R3.01-00 * 0x00000002 0x99CE 614 0/0/0
R3#
路由学不全,没有R2的路由哦
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.123.0/24 is directly connected, Serial1/0
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
i L1 3.3.3.0 [115/20] via 192.168.123.3, Serial1/0
R1#
2.非全互联时DIS可能选举不对,尽管DIS选对了,也无法算路由
将R1的S1/0口ISIS优先级提高
R1(config)#int s1/0
R1(config-if)#isis priority 65
R1(config-if)#exit
R1(config)#
R1#show clns interface s1/0
Serial1/0 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 6 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 65, Circuit ID: R1.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 2
Next IS-IS LAN Level-1 Hello in 2 seconds
R1#
R2#show clns interface s1/0
Serial1/0 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 31 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: R1.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 1 seconds
R2#
R3#show clns interface s1/0
Serial1/0 is up, line protocol is up
Checksums enabled, MTU 1500, Encapsulation FRAME-RELAY
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 18 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: R1.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 620 milliseconds
R3#
但是在R2和R3上路由不全,R2没有R3的路由..,所以一定要全互联
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
C 192.168.123.0/24 is directly connected, Serial1/0
1.0.0.0/24 is subnetted, 1 subnets
i L1 1.1.1.0 [115/20] via 192.168.123.1, Serial1/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
R2#
3.路由学到了,但可以通吗?
从R2到R1环回口的网络,不通。为什么?
R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
帧中继中必须为IP做映射才可以通
R1(config)#int s1/0
R1(config-if)#frame-relay map ip 192.168.123.2 102
R1(config-if)#frame-relay map ip 192.168.123.3 103
R1(config-if)#end
R1#
R2(config)#int s1/0
R2(config-if)#frame-relay map ip 192.168.123.1 201
R2(config-if)#end
R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/44 ms
R2#
R3(config)#int s1/0
R3(config-if)#frame-relay map ip 192.168.123.1 301
R3(config-if)#end
R3#