网络类型
1.Broadcast
2.NonBroadcast
3.Point-to-Multimpoint
4.Point-to-Multimpoint NonBroadcast
5.Point-to-Point
****************************************************
**OSPF网络类型 DR/BDR 手工邻居 HELLO 单播/组播 **
** P2P --- --- 10S 组 **
** P2MP --- --- 30S 单/组 **
** NBMA √ √ 30S 单 **
** Broadcast √ --- 10S 组 **
** P2MP-NBMA --- √ 30S 单 **
****************************************************
--------------------------------
R1
|(S1/0)
|
R2(S1/0)------FR-SW-------(S1/0)R3
--------------------------------
配置如下:
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 123.1.1.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
frame-relay map ip 123.1.1.3 103
frame-relay map ip 123.1.1.2 102
no frame-relay inverse-arp
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 123.1.1.1 0.0.0.0 area 0
neighbor 123.1.1.3 需要手工制定邻居
neighbor 123.1.1.2
!
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 123.1.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart_delay 0
frame-relay map ip 123.1.1.1 201
no frame-relay inverse-arp
!
router ospf 200
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 123.1.1.2 0.0.0.0 area 0
!
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 123.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
serial restart_delay 0
frame-relay map ip 123.1.1.1 301
no frame-relay inverse-arp
!
router ospf 300
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 123.1.1.3 0.0.0.0 area 0
!
-------------------------------
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:01:52 123.1.1.3 Serial1/0
2.2.2.2 0 FULL/ - 00:01:52 123.1.1.2 Serial1/0
--------------------------------
R1#show ip ospf int s1/0
Serial1/0 is up, line protocol is up
Internet Address 123.1.1.1/24, Area 0
Process ID 100, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:12
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 2, Adjacent neighbor count is 2
Adjacent with neighbor 3.3.3.3
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
R1#
----------------------
R1#debug ip ospf hello
OSPF hello events debugging is on
R1#
May 6 18:27:48.015: OSPF: Send hello to 0.0.0.1 area 0 on Serial1/0 from 123.1.1.1
May 6 18:27:48.055: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0 123.1.1.3
May 6 18:27:48.059: OSPF: End of hello processing
May 6 18:27:48.083: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0 123.1.1.2
May 6 18:27:48.083: OSPF: End of hello processing
R1#
May 6 18:28:18.019: OSPF: Send hello to 0.0.0.1 area 0 on Serial1/0 from 123.1.1.1
May 6 18:28:18.063: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0 123.1.1.3
May 6 18:28:18.067: OSPF: End of hello processing
May 6 18:28:18.099: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0 123.1.1.2
May 6 18:28:18.103: OSPF: End of hello processing
R1#
----------------------------
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
O 2.2.2.0 [110/65] via 123.1.1.2, 00:05:34, Serial1/0
3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/65] via 123.1.1.3, 00:05:34, Serial1/0
123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 123.1.1.3/32 [110/64] via 123.1.1.3, 00:05:34, Serial1/0
O 123.1.1.2/32 [110/64] via 123.1.1.2, 00:05:34, Serial1/0
C 123.1.1.0/24 is directly connected, Serial1/0
R1#
---------------
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O 1.1.1.0 [110/65] via 123.1.1.1, 00:05:40, Serial1/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/129] via 123.1.1.1, 00:05:40, Serial1/0
123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 123.1.1.3/32 [110/128] via 123.1.1.1, 00:05:40, Serial1/0
O 123.1.1.1/32 [110/64] via 123.1.1.1, 00:05:40, Serial1/0
C 123.1.1.0/24 is directly connected, Serial1/0
R2#
---------------------------
R2#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 123.1.1.1 44 msec 28 msec 36 msec
2 123.1.1.3 20 msec * 40 msec
R2#