网络类型
1.Broadcast
2.NonBroadcast
3.Point-to-Multimpoint
4.Point-to-Multimpoint NonBroadcast
5.Point-to-Point
****************************************************
**OSPF网络类型 DR/BDR 手工邻居 HELLO 单播/组播 **
** P2P --- --- 10S 组 **
** P2MP --- --- 30S 单/组 **
** NBMA √ √ 30S 单 **
** Broadcast √ --- 10S 组 **
** P2MP-NBMA --- √ 30S 单 **
****************************************************
--------------------------------
R2(S1/0)------FR-SW-------(S1/0.2)R1(S1/0.3)----FR-SW-------(S1/0)R3
--------------------------------
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial1/0.2 point-to-point
ip address 12.1.1.1 255.255.255.0
frame-relay interface-dlci 102
!
interface Serial1/0.3 point-to-point
ip address 13.1.1.1 255.255.255.0
frame-relay interface-dlci 103
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 12.1.1.1 0.0.0.0 area 0
network 13.1.1.1 0.0.0.0 area 0
!
R2:手工映射DLCI
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart_delay 0
frame-relay map ip 12.1.1.1 201 broadcast
no frame-relay inverse-arp
!
router ospf 200
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.1.1.2 0.0.0.0 area 0
!
R3:自动解析DLCI 为Broadcast类型
interface Loopback0
ip address 3.3.3.3 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
ip address 13.1.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
serial restart_delay 0
!
router ospf 300
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 13.1.1.3 0.0.0.0 area 0
!
--------------
R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
3.3.3.3 0 FULL/ - 00:00:34 13.1.1.3 Serial1/0.3
2.2.2.2 0 FULL/ - 00:00:32 12.1.1.2 Serial1/0.2
R1#
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:36 12.1.1.1 Serial1/0
R2#
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:38 13.1.1.1 Serial1/0
R3#
---------------------------------
R1#show ip ospf interface s1/0.2
Serial1/0.2 is up, line protocol is up
Internet Address 12.1.1.1/24, Area 0
Process ID 100, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 64
Transmit Delay is 1 sec, State POINT_TO_POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2
Suppress hello for 0 neighbor(s)
R1#
----------------------------------
R1#
May 6 18:59:02.683: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0.2 12.1.1.2
May 6 18:59:02.687: OSPF: End of hello processing
May 6 18:59:03.291: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.2 from 12.1.1.1
R1#
May 6 18:59:04.835: OSPF: Rcv hello from 3.3.3.3 area 0 from Serial1/0.3 13.1.1.3
May 6 18:59:04.835: OSPF: End of hello processing
R1#
May 6 18:59:10.459: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.3 from 13.1.1.1
R1#
May 6 18:59:12.671: OSPF: Rcv hello from 2.2.2.2 area 0 from Serial1/0.2 12.1.1.2
May 6 18:59:12.675: OSPF: End of hello processing
May 6 18:59:13.291: OSPF: Send hello to 224.0.0.5 area 0 on Serial1/0.2 from 12.1.1.1
R1#
----------------------------
R1#show frame-relay map
Serial1/0.2 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
status defined, active
Serial1/0.3 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
status defined, active
R1#
R2#show frame-relay map
Serial1/0 (up): ip 12.1.1.1 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
Serial1/0 (up): ip 13.1.1.3 dlci 213(0xD5,0x3450), dynamic,
broadcast,, status defined, active
R2#
R3#show frame-relay map
Serial1/0 (up): ip 12.1.1.2 dlci 312(0x138,0x4C80), dynamic,
broadcast,, status defined, active
Serial1/0 (up): ip 13.1.1.1 dlci 301(0x12D,0x48D0), dynamic,
broadcast,, status defined, active
R3#
--------------------------------
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
2.0.0.0/24 is subnetted, 1 subnets
O 2.2.2.0 [110/65] via 12.1.1.2, 00:08:05, Serial1/0.2
3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/65] via 13.1.1.3, 00:08:05, Serial1/0.3
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/0.2
13.0.0.0/24 is subnetted, 1 subnets
C 13.1.1.0 is directly connected, Serial1/0.3
R1#
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
O 1.1.1.0 [110/65] via 12.1.1.1, 00:07:32, Serial1/0
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/129] via 12.1.1.1, 00:07:32, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.1.1.0 is directly connected, Serial1/0
13.0.0.0/24 is subnetted, 1 subnets
O 13.1.1.0 [110/128] via 12.1.1.1, 00:07:32, Serial1/0
R2#
-------------------
R2#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3
1 12.1.1.1 36 msec 60 msec 16 msec
2 13.1.1.3 48 msec * 52 msec
R2#
R2#traceroute 13.1.1.3
Type escape sequence to abort.
Tracing the route to 13.1.1.3
1 12.1.1.1 24 msec 28 msec 8 msec
2 13.1.1.3 56 msec * 36 msec
R2#